Support Center

Troubleshooting LOM-15

  1. Verify the device is powered by 120VAC.

    The LED should be illuminated when the device is in the OFF position.  If this is not the case, check wiring. 

    If wiring is correct and the device still does not power, replace the device.

     
  2. Verify the device is plugged into the bottom receptacle.  Remember only the bottom receptacle is controlled, while the top receptacle is constantly hot.

     
  3. Verify the device controls the connected circuit using its own local control (tapping the middle button.

    If the circuit does not respond, check the lamping to ensure the bulb is not in need of replacement.

    Verify the sound of the internal relay opening and closing can be heard when turning the device ON and OFF.

    If the device still does not control the circuit, replace the device

     
  4. If the device operates the circuit properly but is not being controlled properly by another Evolve device, do NOT replace the hardware. 

    First, verify the device is installed within the correct guest room.  Check the sticker on the device.

    Try “Resending All Data” to the device using the Evolve Device Replacement Tool

    Reset & “Replace Fail” the device into the proper network
3c69ff3e06443603ec0ea37e1dacaab9@evolvesupport.desk-mail.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete